fix includes
[awesomized/libmemcached] / include / libmemcached-1.0 / CMakeLists.txt
index 061c6f7fd374030bc17142ee47ec1e117a45141e..f288c13ef7ab06d4bf4bca00dda53268e4ad4f73 100644 (file)
@@ -1,8 +1,52 @@
 
 configure_file(configure.h.in configure.h @ONLY)
 
-install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
-        DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
-        FILES_MATCHING REGEX "\\.h(pp)?$"
-        PATTERN t EXCLUDE
+add_subdirectory(struct)
+add_subdirectory(types)
+
+install_public_headers(
+        libmemcached-1.0
+
+        alloc.h
+        allocators.h
+        analyze.h
+        auto.h
+        basic_string.h
+        behavior.h
+        callback.h
+        callbacks.h
+        defaults.h
+        delete.h
+        deprecated_types.h
+        dump.h
+        encoding_key.h
+        error.h
+        exception.hpp
+        exist.h
+        fetch.h
+        flush_buffers.h
+        flush.h
+        get.h
+        hash.h
+        limits.h
+        memcached.h
+        memcached.hpp
+        options.h
+        parse.h
+        platform.h
+        quit.h
+        result.h
+        return.h
+        sasl.h
+        server.h
+        server_list.h
+        stats.h
+        storage.h
+        strerror.h
+        touch.h
+        triggers.h
+        types.h
+        verbosity.h
+        version.h
+        visibility.h
         )