Readying for a release
[awesomized/libmemcached] / support / libmemcached.spec
1 Summary: memcached C library and command line tools
2 Name: libmemcached
3 Version: 0.4
4 Release: 1
5 License: BSD
6 Group: System Environment/Libraries
7 URL: http://tangent.org/552/libmemcached.html
8
9 Packager: Jeff Fisher <guppy@techmonkeys.org>
10
11 Source: http://download.tangent.org/libmemcached-%{version}.tar.gz
12 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
13
14 %description
15 libmemcached is a C client library to the memcached server
16 (http://danga.com/memcached). It has been designed to be light on memory
17 usage, and provide full access to server side methods.
18
19 It also implements several command line tools:
20
21 memcat - Copy the value of a key to standard output
22 memflush - Flush the contents of your servers.
23 memrm - Remove a key(s) from the serrver.
24 memstat - Dump the stats of your servers to standard output
25 memslap - Generate testing loads on a memcached cluster
26
27 %prep
28 %setup -q
29
30 %configure
31
32 %build
33 %{__make} %{_smp_mflags}
34
35 %install
36 %{__rm} -rf %{buildroot}
37 %{__make} install DESTDIR="%{buildroot}" AM_INSTALL_PROGRAM_FLAGS=""
38
39 %clean
40 %{__rm} -rf %{buildroot}
41
42 %files
43 %{_bindir}/memcat
44 %{_bindir}/memcp
45 %{_bindir}/memflush
46 %{_bindir}/memrm
47 %{_bindir}/memstat
48 %{_bindir}/memslap
49 %{_includedir}/libmemcached/memcached.h
50 %{_libdir}/libmemcached.a
51 %{_libdir}/libmemcached.la
52 %{_libdir}/libmemcached.so
53 %{_libdir}/libmemcached.so.0
54 %{_libdir}/libmemcached.so.0.0.0
55
56 %changelog
57 * Wed Oct 3 2007 Brian Aker <brian@tangent.org> - 0.4-1
58 - See Changelog
59
60 * Mon Oct 1 2007 Brian Aker <brian@tangent.org> - 0.3-1
61 - Added memslap
62
63 * Fri Sep 28 2007 Jeff Fisher <guppy@techmonkeys.org> - 0.2-1
64 - Initial package