Try multiple postgresql versions
authorMichael Wallner <mike@php.net>
Wed, 29 Jul 2015 07:09:24 +0000 (09:09 +0200)
committerMichael Wallner <mike@php.net>
Wed, 29 Jul 2015 07:09:24 +0000 (09:09 +0200)
See
https://github.com/travis-ci/travis-ci/issues/1651#issuecomment-125212522

.travis.yml

index be39a20..dd9fa3f 100644 (file)
@@ -1,7 +1,6 @@
 language: c
 
 addons:
 language: c
 
 addons:
-    postgresql: "9.3"
     apt:
         packages:
             - libpq-dev
     apt:
         packages:
             - libpq-dev
@@ -21,6 +20,15 @@ env:
         - PHP_TARGET_REF=PHP-5.5 PHP_CONFIGURE_OPTS="--enable-maintainer-zts"
         - PHP_TARGET_REF=PHP-5.6 PHP_CONFIGURE_OPTS=""
         - PHP_TARGET_REF=PHP-5.6 PHP_CONFIGURE_OPTS="--enable-maintainer-zts"
         - PHP_TARGET_REF=PHP-5.5 PHP_CONFIGURE_OPTS="--enable-maintainer-zts"
         - PHP_TARGET_REF=PHP-5.6 PHP_CONFIGURE_OPTS=""
         - PHP_TARGET_REF=PHP-5.6 PHP_CONFIGURE_OPTS="--enable-maintainer-zts"
+        include:
+            - addons:
+                postgresql: 9.1
+            - addons:
+                postgresql: 9.2
+            - addons:
+                postgresql: 9.3
+            - addons:
+                postgresql: 9.4
 
 before_script:
     - ./travis/compile-php.sh
 
 before_script:
     - ./travis/compile-php.sh