better type handling for bool/double params
[m6w6/ext-pq] / config.m4
index bbd3e019cec304fadef0c19d2b38f51d7bf6cbb8..8014c65fbf5a189fb63db65ca912189d03fe546d 100644 (file)
--- a/config.m4
+++ b/config.m4
@@ -1,5 +1,5 @@
-PHP_ARG_WITH(pq, for pq support,
-[  --with-pq             Include pq support])
+PHP_ARG_WITH(pq, [whether to enable libpq (PostgreSQL) support],
+[  --with-pq             Include libpq support])
 
 if test "$PHP_PQ" != "no"; then
        SEARCH_PATH="/usr/local /usr /opt"
@@ -17,13 +17,12 @@ if test "$PHP_PQ" != "no"; then
        done
 
        if test -z "$PQ_DIR"; then
-               AC_MSG_FAILURE(could not find include/libpq-events.h)
+               AC_MSG_ERROR(could not find include/libpq-events.h)
        fi
        PHP_ADD_INCLUDE($PQ_DIR/include)
 
        PQ_SYM=PQregisterEventProc
        PHP_CHECK_LIBRARY(pq, $PQ_SYM, [
-               LDFLAGS="$save_LDFLAGS"
                PHP_ADD_LIBRARY_WITH_PATH(pq, $PQ_DIR/$PHP_LIBDIR, PQ_SHARED_LIBADD)
                PHP_SUBST(PQ_SHARED_LIBADD)
        ],[
@@ -31,8 +30,27 @@ if test "$PHP_PQ" != "no"; then
        ],[
                -L$PQ_DIR/$PHP_LIBDIR
        ])
+       PHP_CHECK_LIBRARY(pq, PQlibVersion, [AC_DEFINE(HAVE_PQLIBVERSION, 1, Have PQlibVersion)])
 
-       PQ_SRC="src/php_pq.c"
-    PHP_ADD_BUILD_DIR($ext_builddir/src, 1)
+       PQ_SRC="\
+               src/php_pq_module.c\
+               src/php_pq_misc.c\
+               src/php_pq_callback.c\
+               src/php_pq_object.c\
+               src/php_pqcancel.c\
+               src/php_pqconn.c\
+               src/php_pqconn_event.c\
+               src/php_pqcopy.c\
+               src/php_pqexc.c\
+               src/php_pqlob.c\
+               src/php_pqres.c\
+               src/php_pqstm.c\
+               src/php_pqtxn.c\
+               src/php_pqtypes.c\
+       "
        PHP_NEW_EXTENSION(pq, $PQ_SRC, $ext_shared)
+       PHP_ADD_BUILD_DIR($ext_builddir/src)
+       PHP_ADD_INCLUDE($ext_srcdir/src)
+    PHP_ADD_EXTENSION_DEP(pq, raphf)
 fi
+