fix PHP-5.4 compatibility┬ž