-release 1.5.1; build failure (PHP5<5.2) due to ZEND_MN misdefinition, thanks Brian
authorMichael Wallner <mike@php.net>
Wed, 21 Feb 2007 15:48:00 +0000 (15:48 +0000)
committerMichael Wallner <mike@php.net>
Wed, 21 Feb 2007 15:48:00 +0000 (15:48 +0000)
missing.h
package.xml
package2.xml
php_http.h

index d411273..521d62a 100644 (file)
--- a/missing.h
+++ b/missing.h
@@ -76,7 +76,7 @@
 #endif
 
 #ifndef ZEND_MN
-#      define ZEND_MN(name) zim_##name
+#      define ZEND_MN(name) ZEND_FN(name)
 #endif
 
 #ifdef WONKY
index f1c0198..bc58c4e 100644 (file)
@@ -23,12 +23,11 @@ support. Parallel requests are available for PHP 5 and greater.
   </maintainer>
   </maintainers>
  <release>
-  <version>1.5.0</version>
-  <date>2007-02-20</date>
+  <version>1.5.1</version>
+  <date>2007-02-21</date>
   <license>BSD, revised</license>
   <state>stable</state>
-  <notes>* Fixed responses to range requests which asked for the first byte (0-0)
-* Fixed Win32 build
+  <notes>* Fixed build with PHP-5 &lt; v5.2
   </notes>
   <deps>
    <dep type="php" rel="ge" version="4.3"/>
index 2edb7b5..a968cb0 100644 (file)
@@ -28,9 +28,9 @@ support. Parallel requests are available for PHP 5 and greater.
   <email>mike@php.net</email>
   <active>yes</active>
  </lead>
- <date>2007-02-20</date>
+ <date>2007-02-21</date>
  <version>
-  <release>1.5.0</release>
+  <release>1.5.1</release>
   <api>1.5.0</api>
  </version>
  <stability>
@@ -39,8 +39,7 @@ support. Parallel requests are available for PHP 5 and greater.
  </stability>
  <license>BSD, revised</license>
  <notes><![CDATA[
-* Fixed responses to range requests which asked for the first byte (0-0)
-* Fixed Win32 build
+* Fixed build with PHP-5 < v5.2
 ]]></notes>
  <contents>
   <dir name="/">
index a9ebaa5..089e365 100644 (file)
@@ -15,7 +15,7 @@
 #ifndef PHP_EXT_HTTP_H
 #define PHP_EXT_HTTP_H
 
-#define PHP_EXT_HTTP_VERSION "1.5.0"
+#define PHP_EXT_HTTP_VERSION "1.5.1"
 
 #ifdef HAVE_CONFIG_H
 #      include "config.h"